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There are two differences between SPSS and the generic language used in the main 
text that are important for this chapter. First, SPSS’s menu route does not allow 
polynomial terms in a continuous variable. This somewhat complicates the menu 
approach to many of the analyses in this chapter, as we fool SPSS into doing the 
required analysis by calculating new variables. The second difference is that there is 
no shorthand way of writing interaction terms—the model A B A*B in most 
languages has a shortcut form, such as A|B, but not in SPSS. Many design 
statements are therefore long, and many menu routes laborious, as a consequence. 
On the other hand, the full factorial model, including all categorical variables, is 
the default model. Users must not fall into the temptation of fitting the full 
factorial model just to avoid the labour of spelling out a more appropriate model. 
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In the early sections of this chapter in the main text, a polynomial model was built 
up by fitting the three models X, X  X*X  and X  X*X  X*X*X. Choices can be 
made between these models on the basis of economy of variables, multiplicity of  
p-values and considerations of marginality. These models cannot be fitted naturally 
in SPSS via the menu route (although they can, curiously, via the syntax route). 
We now demonstrate a technique that manages to fool SPSS into doing the 
required analyses via menus. At the same time we ask SPSS to test the sequential 
(Type I) sums of squares. When testing adjusted (Type III) sums of squares, it is 
necessary to fit three separate models, because only the final p-value is valid. If 
fitting models for which such considerations of marginality come into play, it is 
more efficient and informative to request ANOVA tables based on sequential sums 
of squares, as is shown below for the simple polynomial dataset. 
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To fudge the polynomial terms in the menu route, we calculate the squared and 
cubed terms in new variables called X1P2 and X1P3 (to represent X1 to the 
power 2 and X1 to the power 3 respectively), and include them in the model in 
place of X1*X1 and X1*X1*X1. 
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Syntax glm Y1 with X1 

  /print parameters 

  /method sstype(1) 

  /design X1 X1*X1 X1*X1*X1.�

Menu route Window > Data Editor 

Transform > Compute 

� X1P2 →�Target Variable�

� X1*X1 →�Numeric Expression�

Transform > Compute 

� X2P3 →�Target Variable�

� X1*X1*X1 →�Numeric Expression�

Analyze > General Linear Model > Univariate 

� Y1 → �Dependent Variable�

� X1 X1P2 X1P3 → �Covariate(s)�

� �

� � ��Parameter estimates�

� �

� �� Sum of Squares:   Type I  � 

Model 

Options 
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The DESIGN subcommand and the MODEL subdialog are used here to make 
clear the nature of the model being fitted. They are long-winded, however, and in 
this case can both be omitted altogether. This is because the design is the SPSS’s 
default design, which contains the full factorial combination of all categorical 
variables, plus (though in this case there aren’t any) the continuous variables 
without any of their interactions. We repeat the analyses, once with adjusted and 
once with sequential sums of squares. The commands in bold will produce the 
sequential sums of squares, and omitting these commands will produce the 
adjusted sums of squares (although this also assumes you press the ‘reset’ button in 
the main ‘univariate’ window between analyses in the menu route). Remember the 
convention that BAC & TEMP should be interpreted as selecting the two 
variables together, before clicking on the ‘build terms’ arrow.  
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Dependent Variable: Y1�

6919889.2�a� 3� 2306629.729� 379.382� .000�

7513185.6� 1� 7513185.620� 1235.727� .000�

6663020.6� 1� 6663020.646� 1095.897� .000�

256148.401� 1� 256148.401� 42.130� .000�

720.139� 1� 720.139� .118� .732�

462077.908� 76� 6079.972�

14895153� 80�

7381967.1� 79�

Source�
Corrected Model�

Intercept�

X1�

X1 * X1�

X1 * X1 * X1�

Error�

Total�

Corrected Total�

Type I Sum�
of Squares� df� Mean Square� F� Sig.�

R Squared = .937 (Adjusted R Squared = .935)�a. �

�
(�����	���'�	���	���

Dependent Variable: Y1�

–15.748� 33.924� –.464� .644� – 83.315� 51.818�

6.179� 9.625� .642� .523� –12.991� 25.349�

.617� .697� .885� .379� –.771� 2.005�

4.998E-03� .015� .344� .732� –2.393E-02� 3.392E-02�

Parameter�
Intercept�

X1�

X1 * X1�

X1 * X1 * X1�

B� Std. Error� t� Sig.� Lower Bound� Upper Bound�
95% Confidence Interval�
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Syntax glm ROT by BAC TEMP OXYGEN 

  /method sstype(1) 

  /design BAC TEMP OXYGEN BAC*TEMP BAC*OXYGEN 

TEMP*OXYGEN BAC*TEMP*OXYGEN.�

Menu route Analyze > General Linear Model > Univariate 

� ROT → �Dependent Variable�

� BAC TEMP OXYGEN → �Fixed Factor(s)�

�  

� ��Custom�

� Factors & Covariates�→�Build Terms�→�Model�

� BAC                →���������������BAC 

� TEMP               →���������������TEMP 

� OXYGEN             →���������������OXYGEN 

 BAC & TEMP         →���������������BAC*TEMP 

 BAC & OXYGEN       →���������������BAC*OXYGEN 

 TEMP & OXYGEN      →���������������TEMP*OXYGEN 

 BAC�&�TEMP�&�OXYGEN  →����������������BAC*TEMP*OXYGEN 

 �Sum of Squares+�� Type I  � 

Model 
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18�

18�

18�
27�

27�

18�
18�

18�

1�

2�

3�

BAC�

1�

2�

TEMP�

1�

2�

3�

OXYGEN�

N�

�
#��	���!�$�	���
%&�� ��	��'!!��	�


Dependent Variable: ROT�

1863.704�a� 17� 109.630� 4.680� .000�

4778.963� 1� 4778.963� 204.003� .000�

651.815� 2� 325.907� 13.912� .000�

848.074� 1� 848.074� 36.202� .000�

97.815� 2� 48.907� 2.088� .139�

152.926� 2� 76.463� 3.264� .050�

30.074� 4� 7.519� .321� .862�

1.593� 2� .796� .034� .967�

81.407� 4� 20.352� .869� .492�

843.333� 36� 23.426�

7486.000� 54�

2707.037� 53�

Source�
Corrected Model 

Intercept�

BAC�

TEMP�

OXYGEN�

BAC * TEMP�

BAC * OXYGEN�

TEMP * OXYGEN�

BAC * TEMP * OXYGEN�

Error�

Total�

Corrected Total�

Type I Sum�
of Squares� df� Mean Square� F� Sig.�

R Squared = .688 (Adjusted R Squared = .541)�a. �
�

and the second analysis produces this ANOVA table instead…. 
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Dependent Variable: ROT�

1863.704�a� 17� 109.630� 4.680� .000�

4778.963� 1� 4778.963� 204.003� .000�

651.815� 2� 325.907� 13.912� .000�

848.074� 1� 848.074� 36.202� .000�

97.815� 2� 48.907� 2.088� .139�

152.926� 2� 76.463� 3.264� .050�

30.074� 4� 7.519� .321� .862�

1.593� 2� .796� .034� .967�

81.407� 4� 20.352� .869� .492�

843.333� 36� 23.426�

7486.000� 54�

2707.037� 53�

Source�
Corrected Model�

Intercept�

BAC�

TEMP�

OXYGEN�

BAC * TEMP�

BAC * OXYGEN�

TEMP * OXYGEN�

BAC * TEMP * OXYGEN�

Error�

Total�

Corrected Total�

Type III Sum�
of Squares� df� Mean Square� F� Sig.�

R Squared = .688 (Adjusted R Squared = .541)�a. �
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The same commands are required when orthogonality is lost, but the order of 
the explanatory variables in the model formulae is varied (see main text). 
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First of all we request two extra pieces of output from the original orthogonal 
analysis: a table of means for the significant two-way interaction (BAC*TEMP — 
see Box 10.6), and an interaction diagram. This is done with the following 
commands:
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Syntax glm ROT by BAC TEMP OXYGEN 

  /emmeans tables(BAC*TEMP) 

  /plot profile(BAC*TEMP) 

  /design BAC TEMP OXYGEN BAC*TEMP BAC*OXYGEN 

TEMP*OXYGEN BAC*TEMP*OXYGEN.�

Menu route Analyze > General Linear Model > Univariate 

� ROT → �Dependent Variable�

� BAC TEMP OXYGEN → �Fixed Factor(s)�

� �

� ��Custom�

� Factors & Covariates�→�Build Terms�→�Model�

� BAC              →          ���������BAC 

� TEMP             →          ���������TEMP 

� OXYGEN           →          ���������OXYGEN 

 BAC & TEMP       →          ���������BAC*TEMP 

 BAC & OXYGEN     →          ���������BAC*OXYGEN 

 TEMP & OXYGEN    →          ���������TEMP*OXYGEN 

 BAC�&�TEMP�&�OXYGEN�→          ����������BAC*TEMP*OXYGEN 

 

� BAC*TEMP�→�Display Means for�

� BAC�→�Horizontal Axis�

� TEMP�→��Separate Lines�

�

Plots 

Options 

Model 

Add 
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The following output would then be produced in addition to the ANOVA table: 

Examination of this interaction diagram is what suggests to us that there is a 
directional relationship between ROT and BAC, and that this may even be 
curvilinear at TEMP level 1. This then leads on to the analysis in which BAC is 
declared as continuous and fitted as a polynomial, interacting with TEMP. The 
output for the syntax route and menu route are given separately. Notice that the 
calculated variable BAC2 plays exactly the same role in the menu output as the 
quadratic term BAC*BAC does in the more conventional syntax route. 
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Dependent Variable: ROT�

3.556� 1.613� .284� 6.828�

7.000� 1.613� 3.728� 10.272�

4.778� 1.613� 1.506� 8.050�

13.556� 1.613� 10.284� 16.828�

8.000� 1.613� 4.728� 11.272�

19.556� 1.613� 16.284� 22.828�

TEMP�
1�

2�

1�

2�

1�

2�

BAC�
1�

2�

3�

Mean� Std. Error� Lower Bound� Upper Bound�

95% Confidence Interval�
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Estimated Marginal Means of ROT
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������� glm ROT by TEMP OXYGEN with BAC 

  /method sstype(1) 

  /design OXYGEN TEMP BAC BAC*TEMP BAC*BAC 

BAC*BAC*TEMP.�

�	�
���
�	� 
��������������������

����������������
�	�

� BAC2 →�����	���������	�

� BAC*BAC →��
�	��������	������

 ����!	���"	�	����#��	������	����$��%�����	�

� ROT → ��	�	��	����������	�

� TEMP OXYGEN → �&��	��&�����'�(�

� BAC BAC2 → ���%�����	'�(�

� �

� � ���
�����

� � &�������)���%�����	��→�*
�����	����→����	��

� � OXYGEN            →�������������������OXYGEN 

� � TEMP              →�������������������TEMP 

� � BAC               →�������������������BAC 

  BAC & TEMP        →�������������������BAC*TEMP 

  BAC2              →�������������������BAC2 

  BAC2 & TEMP       →�������������������BAC2*TEMP 

 ��
������+
��	�,��

Model 

Type I  � 
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27�

27�

18�

18�

18�

1�

2�

TEMP�

1�

2�
3�

OXYGEN�

N�

�
�

�
#��	���!�$�	���
%&�� ��	��'!!��	��

Dependent Variable: ROT�

1750.630�a� 7� 250.090� 12.028� .000�

4778.963� 1� 4778.963� 229.852� .000�

97.815� 2� 48.907� 2.352� .106�

848.074� 1� 848.074� 40.790� .000�

650.250� 1� 650.250� 31.275� .000�

148.028� 1� 148.028� 7.120� .010�

1.565� 1� 1.565� .075� .785�

4.898� 1� 4.898� .236� .630�

956.407� 46� 20.791�

7486.000� 54�

2707.037� 53�

Source�
Corrected Model�

Intercept�

OXYGEN�

TEMP�

BAC�

TEMP * BAC�

BAC * BAC�

TEMP * BAC * BAC�

Error�

Total�

Corrected Total�

Type I Sum�
of Squares� df� Mean Square� F� Sig.�

R Squared = .647 (Adjusted R Squared = .593)�a. �
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27�

27�

18�

18�

18�

1�

2�

TEMP�

1�

2�
3�

OXYGEN�

N�

�

�
#��	���!�$�	���
%&�� ��	��'!!��	��

Dependent Variable: ROT�

1750.630�a� 7� 250.090� 12.028� .000�

4778.963� 1� 4778.963� 229.852� .000�

97.815� 2� 48.907� 2.352� .106�

848.074� 1� 848.074� 40.790� .000�

650.250� 1� 650.250� 31.275� .000�

148.028� 1� 148.028� 7.120� .010�

1.565� 1� 1.565� .075� .785�

4.898� 1� 4.898� .236� .630�

956.407� 46� 20.791�

7486.000� 54�

2707.037� 53�

Source�
Corrected Model�

Intercept�

OXYGEN�

TEMP�

BAC�

TEMP * BAC�

BAC2�

TEMP * BAC2�

Error�

Total�

Corrected Total�

Type I Sum�
of Squares� df� Mean Square� F� Sig.�

R Squared = .647 (Adjusted R Squared = .593)�a. �
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We now plot an interaction plot containing both the fitted lines and data. In 
both routes, we ask for a separate line for each group. The groups are defined by 
using the variable TEMP in a legend, in this case separating the groups by colour. 
The lines will not be drawn, however, if TEMP is defined as having a scale of 
measurement, so we have to change this. In the syntax route, we just declare TEMP 
as being CATEGORICAL. In the menu route, we need to make this change in the 
data window. One technicality that is different here is that the variables are moved 
to their appropriate boxes by selecting them, and then dragging with the mouse 
(rather than clicking on a particular arrow to effect the transfer). This is indicated 
by (drag and drop) between two arrows. 
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Syntax igraph 

  /viewname='scatterplot' 

  /x1 = var(BAC) type = scale 

  /y =  var(ROT) type = scale 

  /color = var(TEMP) type = categorical 

  /coordinate = vertical 

  /fitline method = regression linear line = meffect 

  /scatter.�

Menu route Window > SPSS Data Editor 

 Select ‘VariableView’ among tabs at the bottom left 

 Click on the cell in the ‘TEMP’ row and ‘Measurement’ column 

 From the pull-down menu select ‘Ordinal’. You may need to re-import  

 the chapter10data.sav file for this change to take effect.�

�

Graphs > Interactive > Scatterplot 

� ROT�→�(drag and drop)  →�(Y Axis box)�

� BAC�→�(drag and drop) →�(X Axis box) 

� TEMP�→�(drag and drop) →�Color�

� �

� � Method:  

� � � � �

� � Fit lines for: 
� � �����Total�
� � �����Subgroups�

Regression � 



�6�


����	

�	������
 !
�������	�

�"
����	
������
���
��
�����
����������



�

This would produce the following graph (you may not see the colour below 
depending on how you are viewing the file): 
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Linear Regression�
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Ο�

Ο�

Ο�

Ο�

Ο�

Ο�

Ο�

Ο�

Ο�
rot = 1.00 + 2.22 * bac�
R-Square = 0.18�

rot = 0.81 + 6.28 * bac�
R-Square = 0.52�
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Syntax glm Y with X 

  /method sstype(1) 

  /design X X*X X*X*X. 

�

Menu route Window > Data Editor 

Transform > Compute 

� X2�→�Target Variable�

� X*X�→�Numeric Expression�

�

Transform > Compute 

� X3�→�Target Variable�

� X*X*X�→�Numeric Expression�

�

Analyze > General Linear Model > Univariate 

� Y → Dependent Variable�

� X X2 X3 → �Covariate(s)�

� �

� �� Sum of Squares+�� Type I � 

Model 
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The second analysis requires exactly the same commands, substituting XS for X, 
and in the menu route calculating XS2 and XS3 from XS. 
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The SPSS output for this exercise may be found in the answers to exercises. 
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Dependent Variable: Y�

63.753�a� 3� 21.251� 72.705� .000�

3256.398� 1� 3256.398� 11140.902� .000�

.719� 1� .719� 2.460� .121�

.151� 1� .151� .517� .475�

.542� 1� .542� 1.853� .178�

19.876� 68� .292�

74328.371� 72�

83.629� 71�

Source�
Corrected Model�

Intercept�

X�

X * X�

X * X * X�

Error�

Total�

Corrected Total�

Type III Sum�
of Squares� df� Mean Square� F� Sig.�

R Squared = .762 (Adjusted R Squared = .752)�a. �
�

and the second analysis produces the following ANOVA table instead: 
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Dependent Variable: Y�

63.753�a� 3� 21.251� 72.705� .000�

74244.742� 1� 74244.742� 254008.7� .000�

58.906� 1� 58.906� 201.532� .000�

4.305� 1� 4.305� 14.730� .000�

.542� 1� .542� 1.853� .178�

19.876� 68� .292�

74328.371� 72�

83.629� 71�

Source�
Corrected Model�

Intercept�

X�

X * X�

X * X * X�

Error�

Total�

Corrected Total�

Type I Sum�
of Squares� df� Mean Square� F� Sig.�

R Squared = .762 (Adjusted R Squared = .752)�a. �


