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This supplement assumes that you know the basics of using your computer, and 
also how to open and exit SAS. On opening SAS, you will be presented with four 
windows. On the left hand side is an Explorer window which allows you to 
navigate the SAS environment. In the larger right hand side, there are two small 
windows on top—the Log window and an Editor window, and below them is a 
larger Output window. (The precise arrangement of the Editor, Log and output 
windows may vary, and you can arrange them to suit yourself). 

We will do some of our operations in this initial environment. The other half 
will be done within the ‘Analyst’ application. To reach this application, choose 
Solutions > Analysis > Analyst. The explorer window remains, but the right hand 
side of the screen now contains an ‘Analyst’ window with two panes. The left hand 
pane has the structure of the current project displayed, and the right hand pane has 
a spreadsheet for the data. The menu bar has many additional menus when the 
Analyst is running. 

You will need to change between these two environments. You can always move 
to the initial environment by choosing by name one of the windows in the initial 
environment from the Window menu (Log, Editor or Output). You can always 
move to an existing Analyst environment by choosing the Analyst window from the 
Window menu. You can always move to an Analyst environment, and if necessary 
start a new one, by choosing Solutions > Analysis > Analyst. 

The two environments are very different, and we need to discuss entering data 
and commands separately for them. 
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Data can be entered manually in the Analyst environment, by typing into a cell in 
the datasheet and pressing the Return Key. Alternatively, data may have been 
stored from a previous session in a SAS dataset. Using the menus, the dataset could 
be re-opened by the commands: 
File > Open By SAS Name… 

You will be allowed to select the dataset from among the SAS datasets, though it 
may be within a library that you need to open first. If you want to use data from 
any other source, you need to import that data into SAS, using the initial 
environment. (This is described in the next section). The dataset will be opened in 
‘Browse’ mode by default. If you wish to edit the dataset, then you will need to 
choose Edit > Mode > Edit from the menu. 
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In the Analyst environment, commands are issued by menus, mainly the 
Statistics menu. In our tables of instructions which follow, use the ‘Menu route’ 
instructions if you are in the Analyst environment. 
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In the initial environment, the commands are typed into the ‘Editor’ Window, and 
then they are implemented by selecting Run > Submit in the menus, or by clicking 
on the ‘Submit’ icon (a running human figure) in the toolbar that appears below 
the menu bar. In our tables of instructions which follow, you should use the 
‘Commands’ option if working in this environment. You specify which SAS dataset 
you wish to analyse by naming it in the course of the command. If you have an 
external dataset that you want to incorporate into SAS (and this is essential if you 
want to use it within SAS), you can do it from here. SAS can incorporate Excel 
Workbooks, and various other proprietary file types. The data files for this book 
may be downloaded from the web site in the form of Excel files or SAS datasets. 
We will now go through, step by step, how to import a dataset into SAS.  

First, in the initial environment, chose File > Import Data from the menus at 
the top of the screen. The import wizard will then ask you to select a data source 
from a drop down menu. The website datasets are saved in Microsoft Excel 97 – 
choose this option then click on Next. You are then asked where the file is located. 
Use the browse button to select the Excel file for chapter 1 from the location in 
which you have saved it on your computer. Having selected a file, the options 
button underneath this selection pane will become live. Click on this to pick the 
appropriate worksheet from another drop down menu. (Excel files are available in 
two forms: (a) with all datasets for a chapter on one sheet; (b) with each dataset on 
a separate sheet. If using the ‘one sheet’ files this step is not necessary). Having 
done, this, click on OK and Next to arrive at the next dialogue box. Here SAS is 
asking for a ‘member’, by which it means a file name. It will probably be less 
confusing if you use the same file name as the name of the dataset, or the chapter to 
which all datasets belong. The default folder (or library as SAS calls them) is 
‘WORK’. If you save your files here, you will need to renter them every session. 
Later, we will introduce the idea of creating your own folder, so that datasets can 
remain there between sessions. Finally, you are asked if you wish to create a file 
which contains the commands used when importing such files. We suggest that 
you pass on this one and just click ‘finish’. The dataset will now have been 
imported, and your log window should now tell you that work.fertiliser has been 
successfully created.  

We have also provided the datasets in SAS format on the web site. Again these 
are in two forms: (a) all datasets for a chapter in one file; (b) each dataset saved in 
an individual file. For most of the exercises in this supplement, we have assumed 
that the reader uses the ‘whole chapter’ datasets. However, for some operations (e.g. 
sorting the data) it is preferable to use the individual dataset files. The first example 
of this is in the exercises for Chapter 4—and these examples are always indicated in 
the text.  

To view the data, you need to enter the Analyst environment. Do this by 
choosing Solutions > Analysis > Analyst. You will now see an empty spreadsheet. 
Choose File > open by SAS name…, after which you can browse to locate your 
data file. In this case, we need to open the work library to find the dataset fertiliser 
inside. Double click on this and it will appear in the spreadsheet. 

Building up a knowledge of the basic commands will enable you to write 
programs in the SAS language, which may prove useful when analysing similar 
datasets, for bootstrapping, and other simulations. 
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This supplement is designed to be read in conjunction with the main text. The 
section headings and Box numbers correspond to those in the original chapters 
(and so may not be contiguous). 
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Menus were designed to make life easier and more intuitive for the computer user. 
They do this superbly, except in one didactically crucial respect. Writing 
instructions for operating menus is fraught with problems. Some books show 
pictures of the dialog boxes and menus, but this takes up vast amounts of space, 
and can be tolerated only by real beginners to the whole world of modern 
computing. Another possibility is blow-by-blow accounts of the kind ‘Now go to 
the Analyze menu, and choose the General Linear Model submenu, from which 
choose “Univariate…”. A dialog box will appear, and in it, you should…’ and so 
on. This is untidy to look at, easy to get lost in, and painful to read (not to 
mention to write!). 

The solution adopted in this book is to provide a coded set of instructions for 
the menu route. Because menus are so user-friendly, and show the possibilities at 
every stage, only a few key-words need to be given as ‘hints’ to the user. The coded 
instructions are therefore virtually followable without any decoding, and you may 
wish to try this as an experiment! But for the sake of completeness, and to tidy up a 
few rough edges, here are the principles on which the code is based. It is remarkable 
how complicated it is to construct an apparently transparent coding system. 

(1) The initial menu choice.  Instructions always begin with a selection from the 
pop-down menus found at the top of the screen (Macintosh) or window 
(Windows). This is coded by giving the names of the menu, submenu(s) and 
item to be selected, separated by “>”. For example, one frequently used set of 
commands is: 

Statistics > Anova > Linear Models. 

This invariably produces a dialog box. Within a dialog box, there are six kinds 
of actions. The internal actions, those that leave you still looking at the same 
primary dialog box, are Check Box, Radio Button, Pop-up menus, Selection 
and Direction, and Multiple Selection and Direction. There are also buttons, 
some of which bring up a sub-dialog box. Let us look at these in turn. 

(2) Check box.  This will be indicated by a line stating simply “� name of box”. 
When you see this instruction, look for a Check Box (they’re square) and click 
in it. You should see a tick appear in the box to indicate that you have checked 
it. Occasionally, a check box will already contain a tick, indicating a default 
selection. If we wish to deselect this option, this will be illustrated by  “-� 
name of box ”. 

(3) Radio button.  This will be indicated by a line stating simply “� name of 
button”. You may have noticed that Radio Buttons come in sets, and that 
exactly one of the set is active at one time, so that clicking on one makes it 
active, and renders inactive the previously active button. Just look for the radio 
button (they’re round) with that name and click in it. The button should 
change to include a filled circle to indicate that it has become active. 

 

 



�����������	�
�� 

 

(4) Pop-up menus.  This will be indicated by a line stating simply 
 

  

       item for selection 

You should look for the pop-up menu with the name (some other item may be 
currently selected in the menu itself), click on �, and drag up or down to the 
item to be selected, then let go (in some cases you just need to select rather 
than drag and select). Your selection should now appear on the menu button 
or in the appropriate box. 

(5) Selection and direction [when source pane = list of variables].  Lists of 
variables often appear in a source pane in a dialog box, and need to be moved to 
a destination pane for the analysis. First, click on the destination pane, indicating 
your intention to use it. Then you pick a variable in the source pane and 
transfer by double clicking on it or clicking on an arrow between the two 
panes. This will be indicated in various ways, depending on the situation. 
Often there is one source pane, and one destination pane. Then the action will 
be shown as Variable → Destination pane. For example: 

VOLUME → Dependent 

If more than one variable needs to be moved, we will write Variable1 Variable2  
→ Destination pane. For example: 

HEIGHT DIAMETER → Quantitative 

You will see the variable name(s) in the destination pane as confirmation of 
your action.   

(6) Selection and direction when building more complex models.  Sometimes 
moving two variables together has a special meaning, and you need to click on 
a particular button to indicate that meaning. The main examples in this book 
concern model formulae and interactions. In building up a model, you need to 
move variables from one pane to another in a particular order, and sometimes 
select two variables together and click on a particular button. This is best 
illustrated with an example. Suppose we wanted to fit the model VARIETY + 
SOWRATE + VARIETY*SOWARTE. The variables are all listed in a pane 
called “Independent”, and need to be moved to a pane called “Effects in 
Model”. To move a variable, you need to select it and then press a button 
labelled “Add” for the main effects, but for the interaction, you need to select 
the variables together (by holding the shift key down) and press a button 
labelled “Cross”. To make this easier to follow, the panes and the buttons are 
all included in the instructions as follows: 

Independent → Effects in Model 

 VARIETY → Add 

  SOWRATE →  Add 

  (VARIETY & SOWRATE) → Cross 

 

 

name of menu � 
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Note how the lines indicating that an action is required are indented from the 
first line which simply indicates which panes are involved. When building 
models, it is sometimes necessary to control the order in which the variables 
appear in the panes. The default order given by SAS may not be appropriate, 
in which case you need to remove variables. Removing variables from the 
effects in model pane will be indicated as follows: 

Effects in Model 

 BSPACE BVARIETY → Remove 

These instructions are easy to write, and easy to follow, especially in context. 
They are unfortunately confusing to describe! 

(7) Button to sub-dialog.  Typically, a statistics package tries to keep life simple 
for beginners by designing a main dialog box that has few choices; but to allow 
sophisticated users to do complex things by having buttons on the main dialog 
box that lead on to sub-dialog boxes. In statistics packages, there is often a 
whole bank of such buttons. We will indicate their use by illustrating the 
button on a line of its own, and then indicating the actions in the subdialog 
box by indenting them. For example, often there is an options button which 
may lead to further choices. This will be illustrated as follows: 

 

 

    Further subcommands 

When the indentations finish, that means you need to click “OK” or 
“Continue” (but not “Cancel”!) to leave the subdialog box, and continue 
following instructions in the main dialog box. All of the internal actions 
described so far for the main dialog box can also appear in a subdialog box 
(though there are no cases of Buttons to sub-sub-dialog boxes in this book , 
unless you click for Help). The OK or Continue button will not be explicitly 
indicated in the instructions. 
Sometimes clicking on a button executes an action without leading to a new 
dialog box. In these cases there are no indented commands. 

(8) Subpanes.  Occasionally, it is not sufficient to simply state the name of the 
check box. For example, one dialog box gives you the option of saving 
variables, predicted values or residuals any of which may be unstandardised. In 
this case, the name of the appropriate sub-pane will be given, alongside the 
name of its check box. For example: 

� Residuals: Studentized 

� Variables: Predicted Y 

 

 

 

 

 

Name of button... 
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(9) Tabs.  A sub-dialog box occasionally has a number of possible sheets (or 
windows) stacked on top of each other. Each is accessed by clicking on a tab at 
the top of the box—rather like a card index file. If it is necessary to change to 
one of the alternative sheets via a tab, to execute further subcommands, this 
will be stated immediately after the button. For example, if you need to select 
the button “Means”, with a particular tab called “LS Means” this will be 
represented as follows: 

   with LS Means tab 

These principles have been applied to provide a simple and easily 
comprehensible guide to using menus. The equivalent commands in 
‘command editor language’ will also be provided wherever possible. 

Means 


